PHP 버전 차이로 인한 에러 Warning: ini_set(): A session is active. - 그누보드팁

본문 바로가기
전체검색

그누보드팁

그누보드, 영카트 초보 제작자분들을 위한 다양한 스킨 제작 활용 팁을 공유합니다.

PHP 버전 차이로 인한 에러 Warning: ini_set(): A session is active.

관리자 19-02-08 00:10

Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time


그누보드 서버 이전을 했을 때 평소에 안 보이던 위와 같은 에러가 페이지 상단에 나타나는 경우가 있습니다.

PHP 버전업이 되었을 때 주로 발생하네요.

가끔 오래된 그누보드도 살펴볼 일이 있어서 메모겸 남겨놓습니다.



해결 방법


수정 파일 : /common.php


ini_set("session.use_trans_sid", 0);

여기를 이렇게 수정하면 에러가 뜨지 않습니다.

@ini_set("session.use_trans_sid", 0);


하는 김에 바로 밑에 있는 것도 해주세요.

@ini_set("url_rewriter.tags","");


그누보드 5.3 최신 버전에서는 모두 이렇게 되어 있네요.

로그인 후 댓글 작성 가능합니다.

로그인

로그인 후 글 작성 가능합니다.
그누스킨닷컴

그누스터디는 그누보드, 영카트를 이용하시는 초보 사용자를 위한 정보를 공유합니다.

E-MAIL : gnustudy@naver.com / 카카오톡 : gnustudy / 텔레그램 : gnustudy
제작 문의를 제외한 일반 문의는 QA 게시판을 이용해주세요.

Copyright © GNUSTUDY. All rights reserved.